TOPIC: Error Generate Entities from Table
10 months 1 week ago #723
Generate Entities from Table zeigt Fehlermeldung "Error reading metadata"
Datasource: H2 Sample Database
Rapidclipse v3.0

error2.jpg


sample.hibernate.launch:
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<launchConfiguration type="org.hibernate.eclipse.launch.ConsoleConfigurationLaunchConfigurationType">
<listAttribute key="org.eclipse.debug.core.MAPPED_RESOURCE_PATHS">
<listEntry value="sample"/>
</listAttribute>
<listAttribute key="org.eclipse.debug.core.MAPPED_RESOURCE_TYPES">
<listEntry value="4"/>
</listAttribute>
<stringAttribute key="org.eclipse.jdt.launching.PROJECT_ATTR" value="sample"/>
<stringAttribute key="org.hibernate.eclipse.launch.CONFIGURATION_FACTORY" value="JPA"/>
<stringAttribute key="org.hibernate.eclipse.launch.CONNECTION_PROFILE_NAME" value="H2 Northwind"/>
<listAttribute key="org.hibernate.eclipse.launch.FILE_MAPPINGS"/>
<stringAttribute key="org.hibernate.eclipse.launch.HIBERNATE_VERSION" value="5.2"/>
<stringAttribute key="org.hibernate.eclipse.launch.PERSISTENCE_UNIT_NAME" value="sample"/>
<stringAttribute key="org.hibernate.eclipse.launchDIALECT" value="org.hibernate.dialect.H2Dialect"/>
</launchConfiguration>
Attachments:
Last Edit: 10 months 1 week ago by et4dev.
The administrator has disabled public write access.
10 months 1 week ago #724
Moin moin,

selbes Problem existiert auch bei bestehenden MySQL Datasources und auch bei der XdevCloud MySQL Datenbankanbindung.

Edit: Die Version von Hibernate die von RapidClipse als "up-todate" angezeigt wird, ist: Version: 5.1.2.v20161121-1143
In der hibernate.launch Datei ist bereits Version 5.2 eingetragen. Kann es daran liegen?

Besten Gruß
Adriano
Last Edit: 10 months 1 week ago by jodexnis.
The administrator has disabled public write access.
10 months 1 week ago #726
Hallo,
das gleiche Problem habe ich auch mit bestehender Anbindung vom MS SQL Server, welche in Release Candidate 1 angelegt wurde.
Viele Grüße und hoffe auf baldige Lösung,
Lars
The administrator has disabled public write access.
10 months 1 week ago #727
Hallo,
wir arbeiten im Moment an einer Lösung für dieses Problem.
Wir werden sobald wie möglich ein Hotfix dafür bringen.

Euer RapidClipse Team
The administrator has disabled public write access.