TOPIC: Rapidclipse 2.3 Genearator within a generator bug?
11 months 4 weeks ago #378
1. Create a form with a table. (Add an Entity to the table the Northwind database will do. E.g. Product)
1.1 Create a Generator with UI (Typed or otherwise). Add a table then assign an entity to it. E.g. Order.
2. In the newly created Generator add another Generator with UI. Add a table then assign an entity to it. E.g. OrderDetail.
3. In MainView, create a menu. On click of Menu, Display the form created in step 1.

If it's ran in preview everything works fine.
Export it into a window 64 bit desktop app an run it. Open up the form by clicking the menu assignged to the form.
Close the form, it will leave a black square in the screen and doesn't disappear and the app apears to hang.
Exporting into linux desktop app doesn't have this problem. Haven't tried it on OSX or Windows 8 and above. I'm using windows 7.

P.S. I;m generating a fat client. And not embeding the database.
Last Edit: 11 months 4 weeks ago by earlboy.
The administrator has disabled public write access.
11 months 3 weeks ago #387
Hello earlboy,

up to now we were not able to reproduce this behaviour.
Can you give some more informations about your project?

RapidClipse Team
The administrator has disabled public write access.
11 months 2 weeks ago #403
Hi,

Here's what I'm currently doing.
I'm using Maria DB as my database and using My SQL driver from rapidclipse to connect and generate entities.
My main UI (for desktop) has a menu. When I click on to that menu, I display a new window with a table, lets name it "MyWindow".
In the table of "MyWindow", I do the usual, adding columns from the jpa entity I assigned to it, I also create a generated column lets name, it "generated1".
In "generated1" I also add a table, assign a jpa entity to it and add a few columns, then I add another generated column. let's name it "generated2".
In "generated2" I also do the same thing add a column, but I NO LONGER add a generated column to it

Now, when I run this via preview, when I open "MyWinodw", then close it, it works as expected.
But when a generate a fat 64bit windows desktop application using the new export feature of rapidclipse 2.3, and do the same thing mentioned above on Window 7, "MyWindow" leaves a black square when it closes. And does not go away even if I minimize, or refresh the screen. It stays there until I restart the app.

I tried generating a 64 bit linux app from the same project and run it and didn't encounter the problem.
I've also tried running the generated windows app in Windows 8.1 and didn't encounter the problem.

By the way I'm running Windows 7 inside a Virtual Machine (Linux KVM, with passhtrough), and this could be causing the problem. Both OS mentioned above, where I tested without problems were running on real hardware.

Regards,

Earlboy
The administrator has disabled public write access.